Critical PowerShell 7 Code Execution Vulnerability [CVE-2021-26701]

CVE number = CVE-2021-26701

Microsoft is advising users to upgrade their installations of PowerShell 7 as soon as possible to protect themselves against a .NET remote code execution (RCE) vulnerability. 

There are no mitigation steps available to prevent the exploitation of the security issue identified. Customers are advised to update to PowerShell 7.0.6 and 7.1.3 as soon as possible in order to safeguard their systems from potential threats. 

The vulnerable package is System.Text.Encodings.Web . Upgrading your package and redeploying your app should be sufficient to address this vulnerability.

Duncan Newell

Duncan is a technology professional with over 20 years experience of working in various IT roles. He has a interest in cyber security, and has a wide range of other skills in radio, electronics and telecommunications.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: