Grafana Query Editor Cross-Site Scripting Vulnerability [CVE-2018-1000816]

CVE Number – CVE-2018-1000816

A vulnerability in the Influxdb and Graphite query editor of Grafana could allow an unauthenticated, remote attacker to conduct a cross-site scripting (XSS) attack on a targeted system.The vulnerability is due to insufficient validation of user-supplied input by the affected software. An attacker could exploit this vulnerability by persuading a targeted user to select a malicious input field. A successful exploit could allow the attacker to execute arbitrary script code and access sensitive information from the affected interface.Grafana has confirmed the vulnerability and released software updates.

Analysis

  • To exploit this vulnerability, the attacker may use misleading language or instructions to persuade the user to select a malicious input field.

Safeguards

  • Administrators are advised to apply the appropriate updates.Administrators are advised to allow only trusted users to have network access.Users are advised not to open email messages from suspicious or unrecognized sources. If users cannot verify that links or attachments included in email messages are safe, they are advised not to open them.Users are advised not to visit websites or follow links that have suspicious characteristics or cannot be verified as safe.Administrators are advised to use an unprivileged account when browsing the Internet.Administrators are advised to monitor critical systems.

Vendor Announcements

  • Grafana has released an issue report at the following link: issue 13667

Fixed Software

  • Grafana has released a software update at the following link: Grafana 5.3.2

Duncan Newell

Duncan is a technology professional with over 20 years experience of working in various IT roles. He has a interest in cyber security, and has a wide range of other skills in radio, electronics and telecommunications.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: