Security issues in Citrix products reported by researchers [CVE-2019-19781]

CVE number – CVE-2019-19781

Positive Technologies have reported a security issue that affects Citrix products. The flaw could give attackers an opportunity to search for weaknesses on the internet.

Honeypots run by security researchers have shown potential attackers scanning the internet for potentially vulnerable instances. This may put organisations that are exposing them to the open world at risk of being attacked and compromised.

Citrix have published an advisory, which recommends mitigation for customers to apply and advice on how to upgrade all of their vulnerable appliances to a fixed version of the appliance firmware when released.

The vulnerability affects all supported product versions and all supported platforms:

• Citrix ADC and Citrix Gateway version 13.0 all supported builds

• Citrix ADC and NetScaler Gateway version 12.1 all supported builds

• Citrix ADC and NetScaler Gateway version 12.0 all supported builds

• Citrix ADC and NetScaler Gateway version 11.1 all supported builds

• Citrix NetScaler ADC and NetScaler Gateway version 10.5 all supported builds

The following knowledge base article contains the steps to deploy a responder policy to mitigate the issue in the interim until a permanent fix is available: CTX267679 – Mitigation steps for CVE-2019-19781

Jason Davies

UK based technology professional, with an interest in computer security and telecoms.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: