libical icalproperty_new_clone Function Remote Denial of Service Vulnerability [CVE-2016-5823]

CVE Number – CVE-2016-5823

A vulnerability in the icalproperty_new_clone function of libical could allow an unauthenticated, remote attacker to cause a denial of service (DoS) condition on a targeted system.The vulnerability is due to a use-after-free condition in the icalproperty_new_clone function of the affected software. An attacker could exploit this vulnerability by persuading a user to process a crafted ics file on the affected software. A successful exploit could cause a use-after-free condition, resulting in a DoS condition.The vendor has not confirmed the vulnerability; however, software updates are available.

Analysis

  • To exploit this vulnerability, an attacker may use misleading language or instructions to persuade a user to process a crafted ics file that submits malicious input to the targeted system.

Safeguards

  • Administrators are advised to apply the appropriate updates.Administrators are advised to allow only trusted users to have network access.Administrators are advised to use an unprivileged account when browsing the Internet.Administrators are advised to monitor critical systems.Users are advised not to open email messages from suspicious or unrecognized sources. If users cannot verify that links or attachments included in email messages are safe, they are advised not to open them.Users are advised not to visit websites or follow links that have suspicious characteristics or cannot be verified as safe.

Vendor Announcements

  • At the time this alert was first published, The vendor had not released a security advisory.

Fixed Software

  • The vendor has released software updates at the following link: libical releases

Jason Davies

UK based technology professional, with an interest in computer security and telecoms.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: