Security updates available for Adobe Photoshop CC [APSB18-28]

Adobe has released updates for Photoshop CC for Windows and macOS. These updates resolve critical vulnerabilities in Photoshop CC 19.1.5 and earlier 19.x versions, as well as 18.1.5 and earlier 18.x versions.  Successful exploitation could lead to arbitrary code execution in the context of the current user.

Adobe reference = APSB18-28

Affected Product Versions

Photoshop CC 2018 – 19.1.5 and earlier – Windows and macOS

Photoshop CC 2017 – 18.1.5 and earlier – Windows and macOS

Solution

Adobe recommends users update their software installations via each application’s update mechanism by launching each application, navigating to the Help menu, and clicking “Updates.” For more information, please reference this help page.

Photoshop CC 2018 – 19.1.6 – Windows and macOS
Photoshop CC 2017 – 18.1.6 – Windows and macOS

Vulnerability Details

Memory Corruption – Remote Code Execution – Critical – CVE-2018-12810

Memory Corruption – Remote Code Execution – Critical – CVE-2018-12811




Duncan Newell

Duncan is a technology professional with over 20 years experience of working in various IT roles. He has a interest in cyber security, and has a wide range of other skills in radio, electronics and telecommunications.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: