Netgear Security Advisory for Post-Authentication Stack Overflow – PSV-2017-2595

NETGEAR has released fixes for a post-authentication stack overflow security vulnerability on the following product models – Wireless AC Router NightHawk:

  • R7800, running firmware versions prior to 1.0.2.40
  • R9000, running firmware versions prior to 1.0.2.52

NETGEAR strongly recommends that you download the latest firmware as soon as possible.

To download the latest firmware for your NETGEAR product:

    1. Visit NETGEAR Support.
    2. Start typing your model number in the search box, then select your model from the drop-down menu as soon as it appears.
      If you do not see a drop-down menu, make sure that you entered your model number correctly, or select a product category to browse for your product model.
    3. Click Downloads.
    4. Under Current Versions, select the download whose title begins with Firmware Version.
    5. Click Download.
    6. Follow the instructions in your product’s user manual, firmware release notes, or product support page to install the new firmware.




Duncan Newell

Duncan is a technology professional with over 20 years experience of working in various IT roles. He has a interest in cyber security, and has a wide range of other skills in radio, electronics and telecommunications.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: